Вопрос: Определение необходимого репозитория для программного обеспечения


Я являюсь начальным пользователем linux (в настоящее время centOS). Я попытался установить терминаторное приложение терминатора. Я понял, что это не в репозиториях по умолчанию для cent-os, но он должен быть в репозитории epel-release.

Так я и сделал:

yum install epel-release

Это установлено отлично, а затем:

yum install terminator

Но я получаю сообщение об ошибке:

No package terminator available.
Error: Nothing to do

Почему это не работает и как вы узнаете, какой репозиторий вам нужен для определенного программного обеспечения?


1
2018-03-24 21:37


Источник




Ответы:


Выполните следующие шаги, чтобы установить Terminator на новую установку CentOS 7.

Сначала установите репозиторий Extra Packages for Enterprise Linux (EPEL):

yum install epel-release

Затем обновите вновь установленное репо:

yum update

Пакет Terminator содержится в репозитории nux-desktop. Тебе нужно скачать файл rpm, прежде чем вы сможете добавить его в каталог yum.repos.d:

wget http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release- 0-1.el7.nux.noarch.rpm

Затем запустите эту команду, чтобы установить репозиторий:

rpm -Uvh nux-dextop-release-0-1.el7.nux.noarch.rpm

Затем обновите вновь установленное репо:

yum update

Теперь вы можете установить терминатор:

yum install terminator

Терминатор теперь установлен и готов к использованию :)


5
2017-07-10 15:57



Спасибо тебе за это. В предыдущих версиях я получил это от RPMForge и до этого не мог найти работу. - Derokorian


Терминатор не является частью EPEL, Похоже, что это часть Nux-Dextop,

Узнайте больше о различные хранилища, доступные на CentOS,

Это должно работать, если вы используете CentOS 7:

yum install https://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-2.noarch.rpm

yum install http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release-0-1.el7.nux.noarch.rpm

yum install terminator

Стоит отметить, что ваш yum install epel-release скорее всего, установил правильную версию epel-release, поэтому первая строка, вероятно, не требуется.

Удачи!


1
2018-03-25 21:58