Вопрос: компиляция ffmbc на OS X с libvorbis


Я установил libvorbis, и все казалось, что все идет хорошо, и теперь я пытаюсь установить FFmbc с --enable-libvorbis, но он не работает с Error: libvorbis не найден. В файле config.log я получаю:

ld: warning: in /usr/lib/libvorbisenc.a, file was built for unsupported file format which
is not the architecture being linked (x86_64)
ld: warning: in /usr/lib/libvorbis.a, file was built for unsupported file format which
is not the architecture being linked (x86_64)
ld: warning: in /usr/lib/libogg.a, file was built for unsupported file format which
is not the architecture being linked (x86_64)
Undefined symbols:
  "_vorbis_info_init", referenced from:
      _main in ffconf.00FIGmPr.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
ERROR: libvorbis not found

похоже, что-то связано с компиляцией libvorbis для x86_64? Я просто сделал стандартный

./configure  && make && sudo make install 

когда я установил libvorbis, я попробовал

./configure CC="gcc -arch x86_64" CXX="g++ -arch x86_64"

а также

./configure --build=x86_64

но ничего не получилось. Все остальные зависимости (libx264, libfaac libmp3lame и т. Д.) Работали, а не libvorbis.

Это OS X 10.6.8


1
2017-09-29 04:32


Источник




Ответы:


Я не могу говорить за Snow Leopard, однако на Lion 10.7.3 я использовал это для vorbis:

$ env CFLAGS="-O -g -arch x86_64" LDFLAGS="-isysroot /Developer/SDKs/MacOSX10.7.sdk -mmacosx-version-min=10.7 -arch x86_64" ./configure --prefix=${TARGET} --with-ogg-libraries=${TARGET}/lib --with-ogg-includes=/Volumes/Ramdisk/sw/include/ --enable-static --disable-shared && make -j 4 && make install

0
2018-05-01 20:28



Можете ли вы объяснить, что делает эта команда? - bwDraco