Вопрос: Попытка запустить Apache, но рабочая станция VMWare блокирует порт 80


Когда я запускаю сервер Apache, он показывает, что порт 80 занят, потому что рабочая станция WMOB блокирует его. Как запустить Apache?


4
2018-04-20 13:07


Источник


Какая версия VMware Workstation? На какой ОС вы работаете на рабочей станции VMware? - George M
Вы пытаетесь запустить сервер Apache на хосте или виртуальной машине? Вы используете NAT или мостовую сеть для виртуальной машины? - erikxiv
@uther версия 8.0 работает ubuntu - shiva
@erikxiv im работает на сервере apache на сервере и да использует NAT для виртуальной машины - shiva


Ответы:


Из VMWare Статья базы знаний

Подключение к общим виртуальным машинам

Подключение к серверу VMware Workstation Server (общие виртуальные машины) администрируется службой агента VMware. Служба использует TCP-порты 80 и 443. Эта служба также используется другими продуктами VMware, включая VMware Server и vSphere, и предоставляет дополнительные возможности.

Настройка общих виртуальных машин

С настройками рабочей станции общей виртуальной машины вы можете отключить / включить сервер, назначить другой порт для подключения и изменить каталог общих виртуальных машин.

Чтобы получить доступ к настройкам рабочей станции общей виртуальной машины:

  • Перейдите в меню «Редактирование»> «Настройки».
  • Перейдите на вкладку «Общие виртуальные машины».

9
2018-04-20 14:41



Это должны быть принятые ответы. Помогает мне! - swdev


VMWA обычно блокирует порт 443 для совместного использования между удаленными системами. Это может блокировать apache на xampp. Чтобы решить эту проблему,

открыть VMWare, Перейдите в меню «Редактирование»> «Настройки». Нажмите Общие виртуальные машины.

DISABLE SHARING, и это означало бы, что порт 443 закрыт для доступа VMWare, и ваш apache на Xampp будет работать нормально!


2
2018-03-24 14:51