Вопрос: Vim копировать / вставлять испортить indentaton


Всякий раз, когда я копирую что-то из другого приложения, а затем отправляюсь вставлять его в vim, он испортит отступы.

Например, только сейчас я попытался скопировать файл manifest.json из учебника hello-world для создания chrome-расширений.

Это выглядит так:

{
  "manifest_version": 2,

  "name": "One-click Kittens",
  "description": "This extension demonstrates a browser action with kittens.",
  "version": "1.0",

  "permissions": [
    "https://secure.flickr.com/"
  ],
  "browser_action": {
    "default_icon": "icon.png",
    "default_popup": "popup.html"
  }
}

но, когда я вставляю его в vim, он выглядит так: enter image description here

Мой vimrc выглядит следующим образом:

"se t_Co=256
syntax enable

set nowrap
set mouse=a
set tabstop=4
set softtabstop=4
set shiftwidth=4
set expandtab 
set number
set showcmd
set cursorline
set showmatch

execute pathogen#infect()
"filetype plugin indent on

"folding settings
set foldmethod=indent   "fold based on indent
set foldnestmax=10      "deepest fold is 10 levels
set nofoldenable        "dont fold by default
set foldlevel=1            

set clipboard=unnamed  "share one clipboard for everyhting    

Это как-то связано с этой строкой:

execute pathogen#infect() "filetype plugin indent on

Если я прокомментирую это, проблема решена. Тем не менее, это то, что я использую для достижения автоматического отступа, когда я кодирую в python. Есть ли другой способ получить автоматический отступ?


4
2018-01-10 17:17


Источник


Как вы вставляете среднюю кнопку мыши? Читать :help 'paste' для объяснения и переключения этого параметра до / после вставки или вставки из Vim (через регистр +, например. "+p, - Ingo Karkat
woah, поэтому я всегда вставил, щелкнув правой кнопкой мыши и выбрав пасту, но я просто попробовал ее с помощью средней кнопки мыши, и она работала, как ожидалось. - Luke
Ах, отлично! Я включил свой комментарий в правильный ответ; пожалуйста, примите его, щелкнув галочку рядом с ним. - Ingo Karkat


Ответы:


В терминале Vim не может различать типизированный текст (там, где требуется автоматический отступ) и вставляемый текст. Так что есть 'paste' вариант (и 'pastetoggle' для упрощения обработки), который при установке отключает автоматическое форматирование и включение. Альтернативой является использование графического GVIM, который может обнаружить это.

Или вы используете доступ к буферу Vim (если он настроен и работает, что вам нужно попробовать), и используйте "* / "+ регистры для выбора / системного буфера обмена, например. с помощью "+p или :put +, Возможно, приклеивание с помощью средней кнопки мыши просто работает; попробуйте!


5
2018-01-10 19:07





: установить пасту

или см. http://vim.wikia.com/wiki/Toggle_auto-indenting_for_code_paste

(herearesomecharsbecausesuperuser.comthinksshortanswersarenotanygoodanswers)


4
2018-01-10 17:43



Это не устранило проблему - Luke


Одна из возможностей, которая не может быть для вас вариантом, заключается в использовании gvim вместо vim, Последний способен отличать вставку от быстрого ввода текста. Из vimпомощь для :paste:

'paste'                 boolean (default off)
                         global                        {not in Vi}
        Put Vim in Paste mode.  This is useful if you want to cut or copy
        some text from one window and paste it in Vim.  This will avoid
        unexpected effects.
        Setting this option is useful when using Vim in a terminal, where Vim
        cannot distinguish between typed text and pasted text.  In the GUI, Vim
        knows about pasting and will mostly do the right thing without 'paste'
        being set.  The same is true for a terminal where Vim handles the
        mouse clicks itself.
        This option is reset when starting the GUI.  Thus if you set it in
        your .vimrc it will work in a terminal, but not in the GUI.  Setting
        'paste' in the GUI has side effects: e.g., the Paste toolbar button
        will no longer work in Insert mode, because it uses a mapping.
        When the 'paste' option is switched on (also when it was already on):
                - mapping in Insert mode and Command-line mode is disabled
                - abbreviations are disabled
                - 'textwidth' is set to 0
                - 'wrapmargin' is set to 0
                - 'autoindent' is reset
                - 'smartindent' is reset
                - 'softtabstop' is set to 0
                - 'revins' is reset
                - 'ruler' is reset
                - 'showmatch' is reset
                - 'formatoptions' is used like it is empty
        These options keep their value, but their effect is disabled:
                - 'lisp'
                - 'indentexpr'
                - 'cindent'
        NOTE: When you start editing another file while the 'paste' option is
        on, settings from the modelines or autocommands may change the
        settings again, causing trouble when pasting text.  You might want to
        set the 'paste' option again.
        When the 'paste' option is reset the mentioned options are restored to
        the value before the moment 'paste' was switched from off to on.
        Resetting 'paste' before ever setting it does not have any effect.
        Since mapping doesn't work while 'paste' is active, you need to use
        the 'pastetoggle' option to toggle the 'paste' option with some key.

1
2018-01-10 18:08





Одним из лучших решений этой проблемы, с которой я столкнулся, является использование плагина с плагинами в скобках: https://github.com/ConradIrwin/vim-bracketed-paste - это позволяет вам вставлять непосредственно в vim, не беспокоясь о том, что отступы выходят наружу .. и без необходимости нажимать разные клавиши перед вставкой и т. д. и т. д.


0
2018-02-06 06:09